Notebook – CEF

CEF - Cisco Express Forwarding
-Both routers and Layer 3 switch both have IOS routing software.
-Software Routing is slow compared to ASICs
L3 switching can use a software and hardware method to move data.
FIB - Fowarding Information Base - Caches Routing Information from the Router supervisor
ADJ Table "routes" (fowards) frames out a port based on mac address information.
ASIC is a name for a switches hardware.
CEF takes L3 routing informaion and caches it to the FIB.
As the switch is booting up, it will look for all the next hop addresses in the routing table
 and pull the MAC addresses from the addresses.
This information is then sent to the adjacency table with all the necessary ARP information.
CEF only tracks routed ports (or interface vlans)
Exceptions to CEF:
Packets with Header options
Packets with TTL expired
Packets destined to use tunnel interfaces
Packets with unsupported encapsulations
Packets required fragmentaion (MTU Exceeded)
----------------------------------------
to turn on CEF:
switch(config)#ip cef
CEF has a feature to watch all traffic statistics.
Will only work for routed interface vlans

show ip cef vlan 200:
shows what ips have been learned by CEF in vlan 200.
ex output:
switch#show ip cef vlan 151
192.168.0.0/24
 attached to Vlan151
The 192.168.0.0/24 was learned on vlan 151
switch#show ip cef 192.168.0.25
192.168.0.25/32
 receive

show ip arp x.x.x.x
shows arp information for the specified IP address, and what interface it was learned on.
Advertisements

Notebook – EtherChannel

Etherchannel - Aggregation of redundant links
Etherchannel takes bundles of redundant links (up to 8 links) and pools the bandwidth into one logical link and load balances all
 traffic across those physical links.
Etherchannel has automatic failover as well.

Port Aggregation Protocol (PAGP) -
Cisco's proprietary etherchannel negotiation protocol.
Port modes: 
.Auto - Will only negotiate an etherchannel with the switch on the other end of the link if other end negotiates it.
.Desirable - Will actively attempt to negotiate an etherchannel port with the other end of the link, 
usually to break the ice in the auto state on the switch on the other end of the link.
.On - Hard coding a port to negotiate an etherchannel.

Link Aggregation Control Protocol (LACP)
Industry standard, declared 802.3AD by IEEE
Port modes: 
.Passive - same as auto 
.Active - same as desirable
.On - same as cisco "on"
------------------------------------------------------------------------------------------------------------------
Layer 2 Etherchannel 
Acts as a normal layer 2 switched bundle of links.
Layer 3 Ether Channel
Turns the Layer 2 Etherchannel into a Port Channel that has routing capabilities.
------------------------------------------------------------------------------------------------------------------
Same config needs to take place on both ends of the link. In order for the etherchannel to be up they other side needs to be configured.
 No configuration on the other with active or passive config the ports will just return to normal switching port.
Switch(config)#interface range fast 0/23 - 24 - select the ports to create the etherchannel
Switch(config-if-range)#channel-protocol <LACP> <PAGP> - select the protocol
Switch(config-if-range)#channel-group <1-64> - assign the etherchannels a group number 
Switch(config-if-range)#channel-group <1-64> <mode [passive/auto][active/desirable][on]>
Will create a new interface called Port-Channel <1-64>. Configuration for L2 etherchannel.

Layer 3 Etherchannel:
(assume port-channel 1 was created out of fast 0/23 and 0/24)
Turn channel group 1 off first:
Switch(config)#interface range fast 0/23 - 24 - selected ports
Switch(config-if-range)#no channel-group 1
Switch(config-if-range)#exit - leave interface range configuration
Switch(config)#interface port-channel 1
Switch(config-if)#no switchport - to remove switching capabilities from this port, and gain routed capabilities
Switch(config-if)#ip address 192.168.1.1 255.255.255.252 - add an ip address to the port channel
Switch(config-if)#interface range fast 0/23 - 24
Switch(config-if-range)#channel-group 1 mode desirable - to create the channel group and place into desirable negotiation mode.

Notebook – HSRP, VRRP, & GLBP

Yes, I’m finally back with more notes that I have been accumulating. I will be posting my notes from time to time, making changes to them over time. Don’t take these notes as a learning source! They’re notes! And most of the time they aren’t even complete!

HSRP, VRRP, GLBP [Not Complete]
 ==================
HSRP - Hot StandBy Router Protocol
-Created by Cisco, 1994 Proprietary
-Uses a default hello timer of 3 seconds with a hold of 10
.Gateways organized into standby groups
.One gateway active, others in standby
.Virtual router IP and MAC address generated
.Hello/3s , Dead/10s
Both gateways will have their own IPs, but the standby group will have one ip address assigned to it but it will generate a virtual mac address.
Virtual MAC address is generated according to ID's:
0000.0c07.acxx
===================|===========|=====================|
         [0000.0C] |[07.AC]    |[xx]                 |
   Cisco Vendor ID |HSRP ID    |Standby Group Number |
===================|===========|=====================|
Clients will use that standby group IP address as their default IP address. This means nothing on the client end of the connection needs to change if one gateway fails.
Gateways will send an ARP message to any downstream switches to have traffic redirected in the right path.
==================
VRRP - Virtual Router Redundancy Protocol
-Created by IETF, 1999
-Open Standard, not proprietary
-Has faster timers than HSRP - Hello 1 seconds, Hold Time 3 seconds
Skew Timer - a timer that starts after a hello is missed + the hold time.
Uses Master and Backup
Stanby Group is called the VRRP Group
Master Router can share virtual IP
If a master sees one of it's tracked interfaces go down it will automtically set it's priority to 0.
==================
GLBP - Gateway Load Balancing Protocol
-Created by Cisco, 2005 Proprietary
-Identical to HSRP but allows active/active connection that enables load balancing.
-GLBP uses 224.0.0.102:3222 as the multicast IP to send/listen for hello packets
-GPBP elects on AVG for each group.
GLBP will use a single IP with Multiple MAC addresses.
Can use Equal or Unequal load balancing.
GLBP will have one single Active Virtual Gateway - Manages the MAC address pools, knows about all other virtual MACs and which ones are assigned to backup routers.
It will respond to ARP requests but will respond with it's Virtual MAC or another router's virtual MAC depending on how load balancing is configured.
Other routers in a GLBP domain will be labeled as Active Virtual Forwarders.
==================
To Setup HSRP:
Create a Standby Group
Select a Primary and a Standby Device.
(Make sure you have a link between the two switches/routers)
Go into the chosen int vlan:
switch(config)#int vlan 25
switch(config-if)#standby group 1 ip 10.1.1.1
(ip is the virtual IP)
switch(config-if)#standby 1 priority 150
routers will have a default of 100.
Higher priority # = higher priority. Higher # will make the switch/router the active router.
Do this same configuration on the other switch/router. However with a lower priority.
show standby - will show standby group statistics

Premption - When a higher priority routers comes back online or is reconverged to a standby group, it tells the other router it will take over as the primary.
Sometimes not a good idea because flapping links/unstable primary (i.e. constant reboots, or hardware failure) will cause outage from deactivating the standby switch/router constantly.
switch(config)#int vlan 25
switch(config-if)#standby 1 preempt (overthrow lower priority designated routers)
Tracking - if a WAN link on the active router fails, it will automatically decrease it's priority number in order to force standby into active. Preempt must be configured.
switch(config-if)#standby 1 track fastEthernet 0/24 50 (reduce priority by 50)
You can set prempt delay using the <minimum swtich>
switch(config-if)#standby 1 prempt delay 90 (wait 90 seconds)
Change timers:
switch(config-if)#standby 1 timers (hello) (dead)
======================
To Setup HSRP:
Configure VRRP Group
switch(config)#int g0/24
switch(config-if)#vrrp 10 ip 192.168.1.1
switch(config-if)#vrrp 10 timers advertise (this will advertise to the other backup the hello timer)
no dead time is set because dead time is default x3 the hello timer.
Other switch/router will have a similar configuration
======================
To Configure GLBP:
switch(config)#int g0/24
switch(config-if)#glbp 1 ip 192.168.1.1 (1 is the group number)
switch(config-if)#glbp 1 priority 1-255 (this will elect the AVG, everything else will be the AVF)
switch(config-if)#glbp 1 timers
switch(config-if)#glbp load-balancing (by default uses round-robin method)
host-dependent - load balance equally, source mac determines forwarder choice
weighted - load balance in proportion to forwarder weighting - 1 - 254 / track